#theforeman

/

      • rizonz
        klaas__: for using in post install
      • klaas__
        then it should not be overwritten Han :)
      • rizonz
        klaas__: it should be nicer when we were able to use the installmedua for it like preseed does
      • Han
        klaas__, indeed, it should :-)
      • klaas__
        I have no idea what you're talking about rizonz - but templates are not really part of the installer - you can use your own templates
      • Han
        I already put the omapi key in a separate file so all I have to do is add an include.
      • rizonz
        klaas__: temmplates are not ?, you should better look into them then ;)
      • klaas__
        no, you only have the default templates that are seeded, but if you don't want to use them you're free to use others
      • rizonz
        klaas__: the default ones are far from perfect
      • they are better now but they have faults
      • klaas__
        they are not supposed to be perfect, but its open source -- if you have a different use case you just create your own
      • they are not overwritten by installer
      • rizonz
        what has the installed todo with it?
      • *installer
      • klaas__
        you said you don't rerun installer because it destroys things
      • I said you should be able to rerun the installer without it destroying things :)
      • rizonz
        klaas__: indeed, I run a HA solution, as the guys that run serious foreman installs, they never run it again
      • *ask
      • klaas__
        then you should maybe crontribute to making the installer HA ready :)
      • because in general you should run the installer again, for updates for example
      • akasurde joined the channel
      • rizonz
        klaas__: no that is really not needed at all
      • Han
        I put my /etc/ dir in git. Saves me a lot of guessing.
      • gwmngilfen
        you need to make sure that config changes are correctly applied, and that you have the latest versions of things like the ENC and report processor scripts. re-running the installer is the easiest way to achieve that
      • there are alternatives, but it's the lowest common denominator
      • personally i have the same puppet modules as the installer uses in my puppet manifests, so I'm effectively running it every 30min :P
      • rizonz
        heh
      • I never run the installer again, and I'm pretty sure I never will
      • you just simply can't
      • not even in a default setup
      • gwmngilfen
        thats your opinion, but plenty of people do without issues
      • klaas__
        I'd even go as far as saying most devs think that way ;)
      • renzo joined the channel
      • rizonz
        gwmngilfen: no people like the HA users in here
      • gwmngilfen: it would be nice if there is a scripts that checks all settings, imports them so you can check your installer script
      • gwmngilfen
        thats a small number of people, and definitely not a default setup
      • sure, that'd be great. patches welcome :)
      • rizonz
        gwmngilfen: yeah already thought about it... time time time atm
      • gwmngilfen: do you use local repo's ?
      • gwmngilfen
        package repos?
      • rizonz
        yes, liek you install centos from a local mirror, but then... it doesn't update centos.repo with it like with ubuntu
      • gwmngilfen
        no, i don't, i use the default mirrors when doing network installs (although mostly I use prebuilt images)
      • rizonz
        gwmngilfen: about the patches, I comment now on the community templates, but mmoll seems to do only his thing there as he always did and does... talking about the community feeling
      • gwmngilfen: ok
      • gwmngilfen
        i'm sorry if you feel unfairly treated, please do direct me to examples. personally, I find mmoll to be one of the most dedicated, professional and courteous people in our community
      • rizonz
        gwmngilfen: is it possible to get mediapath without the --url ? or only your mirror URL, so without the release and arch in a template ?
      • gwmngilfen
        i don't think so, but it's been a while. maybe ask on the mailing list
      • rizonz
        gwmngilfen: he does his thing, heis busy, be he is selective, which is not good
      • gwmngilfen: yeah already found only mediapath
      • lots of people asking about it, no clue about a solution
      • there is some wrong kickstart/puppet mix there because of it
      • rizonz is thinking about the most flexible solutino
      • nstrug joined the channel
      • mhulan has quit
      • inecas has quit
      • gmccullough joined the channel
      • sean__ has quit
      • FTBZ has quit
      • xorpaul
        I'm trying to update the organization of a foreman user with hammer 0.7, but my organization name contains a , 'foo, bar' Is there a way to tell hammer that is the name and not two different parameters?
      • klaas__
        usually that should work with quotes or escaping but you should be able to just use the id check --help
      • xorpaul
        klaas__: Ah, I did not see the --organization-ids option. Thanks! Now I just need to rewrite the sync script.
      • dyasny joined the channel
      • devmodem has quit
      • toky joined the channel
      • akasurde has quit
      • Han
        klaas__, the preseed_default.erb also does not support multiple interfaces.
      • mbacovsk_ has quit
      • lero
        hey, I'm using foreman 1.14.2 with foreman-hooks and I'm not getting host's parameters on the json foreman produces.
      • is there a reason for that? :)
      • orabin has quit
      • tbrisker has quit
      • gmccullough has quit
      • klaas__
        Han: I see another PR coming? :) I only use redhat/suse systems so I can't say much to preseed etc
      • FriedBob joined the channel
      • FTBZ joined the channel
      • violetina joined the channel
      • Han
        Yeah, I have to fix this.
      • But it should be a lot easier this time. The debian installer is not as pretty as anaconda, but it sure is easier than autoyast.
      • klaas__
        hehe yeah, the xml autoyast stuff is the most complicated -- I try to not fiddle with it unless I have serious problems ;)
      • thats why I do most of my configuration over puppet and only a very basic system via autoyast
      • Han
        Let's see if my autoyast really supports multiple interfaces.
      • klaas__, that's also a solution.
      • ponders...
      • sean joined the channel
      • klaas__
        I use the example42 network module, it should have sles12 support by now - I saw that my changes got merged a while back :)
      • Han
        yay
      • klaas__
        I do all routing etc inside puppet, not in the templates
      • you just need the interfaces to be up, otherwise you get into trouble because it reports the interfaces as facts during install
      • Han
        ok
      • sean has quit
      • klaas__
        there is a bit of chicken-and-egg problem if you use the foreman interfaces inside puppet :)
      • lucasdiedrich joined the channel
      • Han
        Yes, I noticed the hard way while I just ran the installer which changed some important settings.
      • For example my apache/sites-* dirs were overwritten. :\
      • jackNemrod joined the channel
      • That was rather uncalled for.
      • mmoll
        Han: I thought preseed does spport that, I see a line "<% @host.managed_interfaces.each do |interface| %>"
      • klaas__
        why do you have custom things in there?
      • mmoll
        Han: vlan and bonding is not supported with preseed for sure
      • Han
        for the mirror
      • gwmngilfen
        han, you know about the -n flag for the installer?
      • it uns puppet in noop mode so you can review the proposed changes
      • *runs
      • klaas__
        Han: you should then maybe try to put everything into puppet using the modules the installer uses -- otherwise you'll run into issues like this again
      • Han
        mmoll, in the debian/ubuntu provisioning template? Then we're talking about another template.
      • gwmngilfen, great tip, cheers!
      • gwmngilfen
        Han: if you didn't already know that, then we need to put that somewhere more obvious in the docs :)
      • mmoll
      • spidernik84 joined the channel
      • Han
        mmoll, ah, there! in the preseed_default.erb there is also some network stuff.
      • In my provisioning network I set no gateway, in the production network I set the gateway. On the installed host the prov. network was configed with an empty gateway and the prod. was not configured.
      • Setting the prod. to primary doesn't work, I get complaints about the machine name.
      • Of course I would love to set the prod network to primary. I mean, that makes most sense.
      • veduardo joined the channel
      • lero
        so, the foreman-hook json is rendered from here right?
      • which just gets from /api/v2/hosts/<id>
      • and when you get from foreman directly, it shows hosts parameters
      • but on the rendered json from hooks nope
      • Han
        klaas__, ok, let's do it your way.
      • sjagtap has quit
      • hprakash has quit
      • jackNemrod_ joined the channel
      • jackNemrod has quit
      • jackNemrod_ is now known as jackNemrod
      • ceso joined the channel
      • mhulan joined the channel
      • TommyTheKid has quit
      • dLobatog has quit
      • nstrug has quit
      • jyejare has quit
      • gmccullough joined the channel
      • LinkRage joined the channel
      • jyejare joined the channel
      • jsherrill_afk is now known as jsherrill
      • aupadhye joined the channel