#stripe

/

      • Tim has quit
      • TheAdversary joined the channel
      • stripe313 joined the channel
      • stripe313
        allo?
      • Tim joined the channel
      • Tim has quit
      • Sorry, afk...if anyone can help with a stripe issue I would appreciate it
      • Hasimir joined the channel
      • jon_x has quit
      • api joined the channel
      • api
        Hello
      • anyone here?
      • stripe313
        dont think so...
      • api
        stripe313: :(
      • daxorid
        nope
      • api
        Hey hpar and everyone I was wondering, How can I get the total volume of my Stripe Account via the Stripe PHP API?
      • daxorid: :(
      • schutt joined the channel
      • schutt
        hello. we are getting increased Stripe connection errors and latency
      • stripe313
        anyone know what the cause of "This action requires additional privileges." is in the logs on declined payments?
      • api
        All help is greatly appreciated!
      • markin: I see you on Stack Overflow and stuff and you seem to know a lot about Stripe. Could you help me please?
      • markin
        Driving now, but the only way to get the total volume would be to calculate it
      • schutt: have to tried doing an mtr or traceroute to rule out a networking issue?
      • api
        markin: Oh sorry about that man, alright, thank you. Don't worry about me make sure you get home safely ;)
      • markin
        stripe313: was that a dashboard refund?
      • schutt
        markin: yes. tried from a few different locations
      • SteveIs has quit
      • stripe313
        markin: dashboard new payment
      • markin
        stripe313: so either you don't have the right permissions like read only or you need to relogin
      • stripe313
        marking: have had no issues. the woman entering payments did have the session active pretty much all day. Currently....I cant log into the account so I cant even experiment at the moment!
      • markin: have had no issues before today (correction)
      • markin
        Normally in the dashboard you'll try a payment, it'll get that error, you'll be presented with a popup for your password and it'll retry it with an updated session
      • schutt: id email support then
      • schutt
        markin: thanks
      • zachsnow joined the channel
      • stripe313
        markin: she tried about 3 customers several times....then one of the fails actually went through....followed by more fails. We will try again with a fresh login (which I cant get into for what reason I have no idea)
      • zachsnow
        Aloha, we just bumped into a few APIErrors; example requests: req_96wmQEvuQLxDTQ, req_96wliEuvNW39ua.
      • jon_x joined the channel
      • markin
        zachsnow: would they happen to be Mastercard txns?
      • zachsnow
        Not sure off hand; has there been an issue today?
      • markin
        I don't know if stripe had any issues, I just saw increased latency with Mastercard on some other payment gateways, just my wild guess
      • Doesn't look like any support folk are around
      • zachsnow
        Ah. In any event, no they were VISA.
      • stripe599 has quit
      • ignacio66 joined the channel
      • lenochka joined the channel
      • lenochka is now known as Guest25004
      • nicksloan joined the channel
      • Guest25004 has quit
      • nullrefexc has quit
      • paulparton has quit
      • Veronica joined the channel
      • Veronica is now known as Guest52863
      • Tim joined the channel
      • lexton joined the channel
      • schutt
        zachsnow: we were seeing the same issue across all providers
      • JackyB has quit
      • Guest52863
        I've been looking for some help on our account and emailed last night but am waiting for customer service to get back to me. I have several questions.
      • 1. I am using the checkout, and somehow people are getting past that screen with a success, but then it gets declined when stripe goes to do the payment. Not sure what we did wrong?
      • (This is on an account that does a few thousand dollars of business a day, long time stripe user for 3 years)
      • 2. We also just started allowing bitcoin, but all of these are failing.
      • zachsnow
        schutt: we saw only a handful, but figured I'd share. As a % of transactions it's quite low. We saw requests APIError but the requests were actually successful.
      • Tim has quit
      • schutt
        zachsnow: same for us. Our retries were successful
      • paulparton joined the channel
      • Guest52863
        3. We saw odd failed payments all day, and then all of the sudden we had a lot of successes go through today.
      • Gsham joined the channel
      • stripe313
        Guest52863: what where the logs saying reason for fails?
      • JackyB joined the channel
      • Guest52863
        card declined.
      • markin
        Guest52863: the checkout window just checks if a card is valid. A card can be valid and still have charges decline
      • Guest52863
        And were there any known issues for recurring payments today? If not, we have to dig into our code more to see what we did wrong.
      • markin
        Eg if the customer doesn't have enough money
      • ignacio66 has quit
      • Guest52863
        I see, thank you.
      • checking to see if we are not reading the error response right.
      • stripe313
        Guest52863: "Your card was declined. You can call your bank for details." ?
      • Guest52863
        yeah, wondering if the error stripe sends back wasn't getting read correctly so we didn't tell the user that it was declined properly.
      • markin
        stripe313: so that means the customer's bank / credit card company declined the message
      • It would be a card error exception in most client libraries
      • Guest52863
        thanks. yeah we just updated with new code and used the new checkout process (we used to have a custom form on our site). So we likely missed something on setup. I tried to test everything I could on the dev site, but have a hard time testing failures.
      • trustyhank joined the channel
      • pavel_ joined the channel
      • s2013 has quit
      • we aren't using the libraries because there were no c# libraries when we originally implemented stripe, so we wrote our own.
      • Our dev says he THINK he's fixed it now. TY for your help.
      • stripe313
        markin: yes...that I can deal with. the other error - "invalid_request_error" message: "This action requires additional privileges." is what I don't understand
      • markin
        Test with 4000000000000341
      • stripe313: that one only happens in the dashboard right?
      • stripe313
        markin: yes
      • Guest52863
        I did and got the right error message when I used that for testing. So something else slipped by in my tests.
      • markin
        stripe313: so immediately after it you should have a successful request
      • stripe313
        markin: hmmm. explain why please? (im lost)
      • markin
        stripe313: because the dashboard would see the error, ask you for your password, get an updated authentication token and try the request again
      • FlorianBd has quit
      • pavel_ has quit
      • stripe313
        markin: ok. I was not in office at the time so I didnt experience it - just heard ALLL about it. thanks.
      • ta joined the channel
      • FlorianBd joined the channel
      • ta has quit
      • zachsnow has quit
      • markin: thanks for the help
      • einnjo has quit
      • Sir joined the channel
      • Sir
        hi! new here
      • Sir has quit
      • wonderer21 joined the channel
      • wonderer21
        Hi guys, I have a question. Can you use application_fee when creating a charge on behalf of a connected account?
      • markin
        wonderer21: yes
      • wonderer21
        Thank you so much <3 that was all I needed to know. I was beginning to think it was just for the platform account. Really appreciate it!
      • s2013 joined the channel
      • Tim joined the channel
      • spencdev joined the channel
      • wonderer21 has quit
      • spencdev
        I'm using stripe in test mode, and it's sending double api calls for charges within less than a second of each other. Any reasons on why this would happen?
      • adambc has quit
      • spencdev has quit
      • TDice joined the channel
      • Tim has quit
      • jdcauley has quit
      • TDice
        hey!
      • wesbos joined the channel
      • jdcauley joined the channel
      • schutt has quit
      • stripe258 joined the channel
      • stripe258
        my stripe account still is not working
      • snax joined the channel
      • TDice has quit
      • Guest- has quit
      • stripe258 has quit
      • Gsham has quit
      • fugiman has quit
      • fugiman joined the channel
      • T1m0thy joined the channel
      • nicksloan has quit
      • Gsham joined the channel
      • rainz has quit
      • T1m0thy has quit
      • T1m0thy joined the channel
      • T1m0thy has quit
      • Tim joined the channel
      • jon_x has quit
      • lexton has quit
      • nicolas joined the channel
      • nicolas
        hi
      • I have a question
      • someone here?
      • tjbiddle joined the channel
      • hi