#dokku

/

      • Timer_ joined the channel
      • Friss joined the channel
      • levarnu joined the channel
      • zenirc369 joined the channel
      • `puck
        hello
      • someone want’s to take over the maintenance of my old dokku-acl plugin (now in dokku-community). who can he talk to?
      • pythdasch joined the channel
      • pythdasch
        Hey, does someone know how to setup graphite grafana ? thx in advance
      • drale2k joined the channel
      • drale2k has quit
      • drale2k joined the channel
      • drale2k has quit
      • drale2k joined the channel
      • drale2k has quit
      • geekb4ck_ joined the channel
      • geekb4ck_
        does the default dokku nginx config include the X_FORWARDED_FOR header? I'm not getting the correct remote_ip in my rails app.
      • gliderbot
      • <savant> this is our default
      • <savant> @scjody you want commit bit on dokku-acl?
      • <flashios09> hi
      • geekb4ck_
        yup. on line 32. hmmmm
      • gliderbot
        <flashios09> i have a fresh ubuntu 16.04 server, i tried to install dokku(it works for me on a VM) but i have this error
      • <flashios09> ``` failed to register layer: devmapper: Error mounting '/dev/mapper/docker-8:1-1051568-034e38f4242d716143151a7c576020ec60689f80954412ec15551df43c997463' on '/var/lib/docker/devicemapper/mnt/034e38f4242d716143151a7c576020ec60689f80954412ec15551df43c997463': invalid argument ```
      • drale2k joined the channel
      • drale2k has quit
      • <flashios09> i found this on github https://github.com/docker/docker/issues/29798
      • <flashios09> but when i try to do `apt full-upgrade` i have the same error :(
      • drale2k joined the channel
      • <scjody> @savant I’m happy to be the maintainer if you still need one. It needs some fixes to work with 0.8.x properly, and I’d like to allow restricting read access to other peoples’ repos. If you prefer I can submit PRs though.
      • cob joined the channel
      • drale2k has quit
      • drale2k joined the channel
      • <flashios09> i don’t know how but it works now after rebooting the server and reinstalling dokku
      • geekb4ck_
        scjody: any time i've seen someone start maintaining a project, they submit PRs and are asked by the existing maintenance team. not saying it won't happen, just unusual from my experience. :)
      • drale2k has quit
      • gliderbot
        <savant> @scjody i gave you commit bit
      • <savant> have fun!
      • <savant> @flashios09 sounds like a docker bug
      • <scjody> Thanks!
      • <savant> wompers
      • <savant> @scjody no problem
      • <flashios09> @savant i didn’t install `docker` !
      • drale2k joined the channel
      • <savant> our bootstrap script installs docker via their bootstrap script
      • <savant> dokku depends on docker.
      • <flashios09> i know, i mean i didn’t install it manually
      • <savant> still its a docker issue
      • <savant> not a dokku issue
      • <savant> nothing I can do if docker is failing
      • drale2k has quit
      • <flashios09> it works now after rebooting the server and reinstalling dokku, the answer that i found on docker github said that’s a problem with `devicemapper` and we should use `aufs`
      • <savant> mmm
      • <savant> aufs is tasty
      • <flashios09> > First of all, I would not recommend running with devicemapper on Ubuntu; the default storage driver is aufs, and on modern (4.x) kernels, the overlay2 storage driver is a good choice.
      • <flashios09> take a look at this(if you want)
      • <flashios09> when i do `docker info` i have this warning
      • <flashios09> ``` Data loop file: /var/lib/docker/devicemapper/devicemapper/data WARNING: Usage of loopback devices is strongly discouraged for production use. Use `--storage-opt dm.thinpooldev` to specify a custom block storage device. Metadata loop file: /var/lib/docker/devicemapper/devicemapper/metadata ```
      • <flashios09> do you think that this warning can cause me problems ? now it works for me
      • <savant> it will cause perf issues probably
      • <savant> again, you should use aufs
      • <flashios09> my vm(ubuntu 16.04) use aufs, my server(ubuntu 16.04) use devicemapper
      • <flashios09> that’s why i didn’t have this error before
      • callahad
        savant: When you get a chance, would you mind glancing over the approach I'm taking in https://github.com/dokku/dokku-redirect/compare... and letting me know if it seems reasonable?
      • (Trying to add support for custom redirect HTTP codes)
      • gliderbot
        <savant> default is still 301?
      • callahad
        yep
      • gliderbot
        <savant> needs tests callahad
      • callahad
        Tests will be added before submitting a pull request
      • Just making sure the general approach looks sane to you
      • gliderbot
        <savant> seems fine otherwise
      • <savant> though I’d pull out that positional argument into a variable
      • callahad
        The ${5:-301}? Easy enough to do
      • gliderbot
        <flashios09> @savant just a stupid question, the storage engine is something related to docker not to ubuntu, i mean i have to change only some docker config ?
      • <savant> probs
      • <savant> i think you need to install a kernel ext or something
      • <savant> i dont know, I always use aufs
      • drale2k joined the channel
      • drale2k has quit
      • <flashios09> when i do `uname -r`, i have `4.4.0-66-generic`(samething for vm that use aufs)
      • drale2k joined the channel