#devuan

/

      • Enrico_Menotti
        Ok, let me try. I need a minute: with this tiny keyboard...
      • prefection joined the channel
      • prefection has quit
      • rrq
        oops second command slightly wrong.
      • Enrico_Menotti
        Something strange: I get: umount: /dev/pts: mountpoint not found. How is that possible?
      • There's a /dev/ptmx.
      • rrq
        hmm. not sure. an alternative could be to use "ssh user@host '/bin/bash -i'" ... doesn't solve it but should let you in
      • (from the client end)
      • Enrico_Menotti
        Ok, but I'd like to solve the problem.
      • rrq
        yes, you'll need someone knowing n900 ..
      • Enrico_Menotti
        The problem, I think, is more Devuan-related, since with Debian I don't have this problem (still on the n900).
      • rrq
        ok. try: mount -t devpts -oremount none /dev/pts
      • DGMurdockIII joined the channel
      • Enrico_Menotti
        With a space between -o and remount?
      • rrq
        nope
      • Atepa has quit
      • or can be
      • Enrico_Menotti
        Again, the mount point does not exist.
      • rrq
        hmm sounds like a problem with /dev
      • Enrico_Menotti
        Maybe I'm missing a kernel module. It may be.
      • rrq
        try "ls -l /dev | grep pts"
      • Atepa joined the channel
      • Enrico_Menotti
        I already listed /dev. No pts. I'll try with the -l option.
      • Nothing.
      • rrq
        ok. "mkdir /dev/pts" then the mount -oremount command
      • Enrico_Menotti
        /dev/pts not mounted or bad option.
      • rrq
        hmm "mount -t devpts none /dev/pts"
      • Enrico_Menotti
        Ok. Let me try with ssh.
      • Ok, this time I'm inside. So now we know the problem, but how to actually solve it?
      • infobot has quit
      • rrq
        normally the static setup of /dev, including /dev/pts, is done by the initrd init script. But I'm not sure if n900 has an initrd?
      • Enrico_Menotti
        No initrd in my case.
      • But also with Debian...
      • thijso has quit
      • rrq
        right; yes, I don't know its startup sequence. Neither of them, but obviously the static setup is missing/lacking in the Devuan startup.
      • is /dev a tmpfs or a persistent directory?
      • Enrico_Menotti
        I don't know...
      • rrq
        "mount | grep /dev"
      • infobot joined the channel
      • Fervi
        udev on /dev type devtmpfs (rw,nosuid,relatime,size=6139096k,nr_inodes=1534774,mode=755)