#devuan

/

      • Enrico_Menotti
        Ok, let me try. I need a minute: with this tiny keyboard...
      • prefection joined the channel
      • prefection has quit
      • rrq
        oops second command slightly wrong.
      • Enrico_Menotti
        Something strange: I get: umount: /dev/pts: mountpoint not found. How is that possible?
      • There's a /dev/ptmx.
      • rrq
        hmm. not sure. an alternative could be to use "ssh [email protected] '/bin/bash -i'" ... doesn't solve it but should let you in
      • (from the client end)
      • Enrico_Menotti
        Ok, but I'd like to solve the problem.
      • rrq
        yes, you'll need someone knowing n900 ..
      • Enrico_Menotti
        The problem, I think, is more Devuan-related, since with Debian I don't have this problem (still on the n900).
      • rrq
        ok. try: mount -t devpts -oremount none /dev/pts
      • DGMurdockIII joined the channel
      • Enrico_Menotti
        With a space between -o and remount?
      • rrq
        nope
      • Atepa has quit
      • or can be
      • Enrico_Menotti
        Again, the mount point does not exist.
      • rrq
        hmm sounds like a problem with /dev
      • Enrico_Menotti
        Maybe I'm missing a kernel module. It may be.
      • rrq
        try "ls -l /dev | grep pts"
      • Atepa joined the channel
      • Enrico_Menotti
        I already listed /dev. No pts. I'll try with the -l option.
      • Nothing.
      • rrq
        ok. "mkdir /dev/pts" then the mount -oremount command
      • Enrico_Menotti
        /dev/pts not mounted or bad option.
      • rrq
        hmm "mount -t devpts none /dev/pts"
      • Enrico_Menotti
        Ok. Let me try with ssh.
      • Ok, this time I'm inside. So now we know the problem, but how to actually solve it?
      • infobot has quit
      • rrq
        normally the static setup of /dev, including /dev/pts, is done by the initrd init script. But I'm not sure if n900 has an initrd?
      • Enrico_Menotti
        No initrd in my case.
      • But also with Debian...
      • thijso has quit
      • rrq
        right; yes, I don't know its startup sequence. Neither of them, but obviously the static setup is missing/lacking in the Devuan startup.
      • is /dev a tmpfs or a persistent directory?
      • Enrico_Menotti
        I don't know...
      • rrq
        "mount | grep /dev"
      • infobot joined the channel
      • Fervi
        udev on /dev type devtmpfs (rw,nosuid,relatime,size=6139096k,nr_inodes=1534774,mode=755)
      • rrq
      • rrq
        .. on the n900 I mean
      • Fervi
        ach
      • rrq
        bbl
      • Enrico_Menotti
        Ok.
      • I'll go to bed in a while.
      • agrecascino
        hello
      • so like
      • i installed devuan
      • and i borked the bootloader
      • how do i fix it
      • lowee[m]
        efi or not efi?
      • agrecascino
        not efi
      • like it failed to load the normal module
      • nighty-- joined the channel
      • fsmithred
        <fsmithred> Advanced options
      • <fsmithred> Rescue mode
      • <mwarning> ok, sec
      • <fsmithred> set language, locale, time zone, hostname, network
      • <fsmithred> then select the root of the installed system
      • lowee[m]
        i'd probably try reinstalling grub2 with a linux live cd
      • fsmithred
        <fsmithred> then Reinstall GRUB boot loader
      • agrecascino
        okay
      • fsmithred
        installer CD should work
      • Achylles joined the channel
      • agrecascino
        fails
      • error: not a correct XFS inode
      • error: attempt to read or write outside of partition
      • rrq has quit
      • rrq joined the channel
      • lowee[m]
        did you use a shell to install grub?
      • agrecascino
        no, i used the rescue cd
      • rrq has quit
      • lowee[m]
        see if you can find a shell and if grub-install is available
      • agrecascino
        can i just install lilo?
      • lowee[m]
        if you know how to do it sure ;)
      • agrecascino
        i mean like
      • is there a package on the install cd
      • lowee[m]
        i do not know, maybe you can install it wirh apt, depending on which cd you use
      • (the package to install lilo i meen)
      • mwarning
        hi, can I install debian packages on devuan? I need rustc.
      • lowee[m]
        for the most part yes (if it is available in debian repos then the same version schould be available in the devuan repos)
      • though you can always install it wqith the rust installer from the webaite
      • golinux
        Installing outside the devuan repos means that the pkg will not have the Devuan versioning which can lead to complications later.
      • mwarning
        k
      • golinux
        If it's in Debian it should be in Devuan.
      • thijso joined the channel
      • debgeek joined the channel
      • lowee[m]
        cated a file and now all my chars in the console are random characters, anyway to fix this ? :g
      • nazmo has left the channel
      • AntoFox joined the channel
      • Fervi has quit
      • debgeek has quit
      • agrecascino
        alright
      • so i can't figure out lilo
      • so how do i fix grub2
      • AntoFox has quit
      • thijso has quit
      • thijso joined the channel
      • lowee[m]
        if i remember correctly you schould be able to run grub-install /dev/sdx (on no efi anywat, dunno about efi)
      • sdx beeing the harddrive you boot from
      • catprints has left the channel
      • Humpelstilzchen has quit
      • mwarning
        ok, thanks for all the help
      • gn8
      • mwarning has quit
      • Humpelstilzchen joined the channel
      • agrecascino
        lowee[m], yeah
      • i've ran it
      • i just get that xfs issue
      • lowee[m]
        i have no idea what that could be, sorry :(
      • fsmithred
        when you format with xfs, how much space does it leave before the beginning of the first partition?
      • grub needs more than the mbr. gparted automatically leaves 1MB free before the first partition.
      • but I don't know anything about xfs
      • agrecascino
        ok like how do i setup lilo then
      • chomwitt joined the channel
      • fsmithred
        sorry, I don't remember. Last time I did that was 10 years ago.
      • apt-get install lilo
      • edit lilo.conf
      • then run /sbin/lilo
      • that's all I remember
      • agrecascino
        yeah i got that part
      • but like
      • fsmithred
        oh, I just wrote a howto for extlinux
      • agrecascino
        it doesn't seem to be loading the intird
      • because it immediately kernel panics saying it couldn't mount the root partition
      • fsmithred
        do you know if lilo works with xfs?
      • agrecascino
        fsmithred, 99% sure, since my slackware setup is on xfs
      • fsmithred
        ok, that's pretty good evidence
      • zjason joined the channel
      • misto6 joined the channel
      • Atepa has quit
      • misto6_ has quit
      • Atepa joined the channel
      • bjb has quit
      • Xenguy has quit
      • bjb joined the channel
      • Xenguy joined the channel
      • bn_ has quit
      • Achylles has quit
      • Atepa has quit
      • bn_ joined the channel
      • bjb has quit
      • Xenguy has quit
      • bjb joined the channel
      • bjb
        I found the manual for the SBC ... Via pc2500E. Press DEL to get into BIOS.
      • Maybe the CDROM HW itself isn't working properly. I will have to find another one and try it.
      • and/or try this one on a different computer
      • Well some other time.
      • I'm out of weekend