2018 03 01

      • MonsterCookies joined the channel
      • cssko joined the channel
      • konishi joined the channel
      • patarr has quit
      • vpandey joined the channel
      • tmornini joined the channel
      • tmornini_ joined the channel
      • tmornini_
        Hello all. Been working on a new Jenkins deployment and would love some help. 🙂
      • Everything seems to be working OK on the master node. Having issues connecting a macmini remote.
      • Have the mini running the Java client and connecting, but produces a stack trace on job execution
      • colemickens has quit
      • tmornini has quit
      • the main failure, if I read the backtrace correct, is: Caused: java.io.IOException: remote file operation failed: /tmp/jenkins/workspace/monorepo_PR-12-EL6ZJETVAM7HBI243FZUDLZTYBE5Z4WN2SSKPKKCK6ATN5SEULZQ at [email protected]:JNLP4-connect connection from 64.79.112.154/64.79.112.154:49419
      • schristou
        is the agent a jnlp agent, or ssh agent?
      • tmornini_
        jnlp
      • wrouesnel_ has quit
      • wrouesnel joined the channel
      • schristou
        would it be possible to use ssh instead?
      • autojack
        jglick: markewaite: stephenc: per my question yesterday, I just tested this again. I have an ssh key credential with passphrase entered, stored in Jenkins. I have a Pipeline job which has a git step with "credentialsId: 'owen'" argument.
      • when I run it, in the console where Jenkins is running, I still get prompted: "Enter passphrase for key '/Users/owen/.jenkins/jobs/gitlab-plugin/wo...;
      • I enter the same passphrase that I entered when I created the Credential, and then the git clone runs fine.
      • malex has quit
      • so I am *guessing* this is a problem with Credentials, not git or pipeline.
      • jglick
        autojack: sounds like a bug in `git-client` around `GIT_ASKPASS`; maybe platform-specific
      • tmornini_ has quit
      • autojack
        OK. up to now I had assumed I was just doing something wrong.
      • markewaite
        autojack: I doubt the problem is with credentials. Command line git and passphrase protected credentials have all sorts of challenges
      • Does the passphrase include a character which is special to the shell?
      • autojack
        I am happy to collect more details and file something if you want. the only other thing I would say is that my passphrase has a special char in it.
      • heh
      • it has an @
      • moas joined the channel
      • markewaite
        That character should be fine.
      • autojack
        ok. that is the only one then.
      • rtyler
        markewaite: aren't you supposed to be presenting a talk? 😛
      • markewaite
        I'll have to check tomorrow
      • autojack
        haha
      • jimklimov has quit
      • markewaite
        I'm in boulder now, ready and waiting to enter the building
      • rtyler
        ah
      • markewaite
        Talk in 35 minutes
      • rtyler
        GET HYPE
      • Slide-O-Mix
        womp womp
      • autojack
        markewaite: I will circle back with you tomorrow, I should be doing other work today as well.
      • Slide-O-Mix steals rtyler's line
      • rtyler
        heh
      • tmornini joined the channel
      • CodeMouse92__ joined the channel
      • sabre1041 joined the channel
      • binaryking has quit
      • mbenson has quit
      • sabre104_ joined the channel
      • sabre1041 joined the channel
      • psiroky has quit
      • pewllet has quit
      • esberglu has quit
      • sabre104_ joined the channel
      • ky13__ joined the channel
      • ky13__ has quit
      • ky13__ joined the channel
      • ky13_ has quit
      • tmornini
        schristou: Yes, I can give that a shot. Does the JNLP agent have issues?
      • schristou
        tmornini: nothing really. I personally prefer ssh when doing *nix environments.
      • tmornini has quit
      • Ney
        Windows jenkins is hurting me a bit
      • I hav a host entry in my .ssh config
      • zerocoolback joined the channel
      • However, Under Pipeline script from SCM, I get the following Command returned status code 128:
      • ssh: could not resolve hostname "whatever": name or serice not known
      • schristou
        Ney: make sure that the user running the Jenkins service is also the same one who you've configured your .ssh/config information for
      • itdependsnetwork
        Any obvious reason Pipeline from SCM would choose the wrong random branch?
      • antgel_ joined the channel
      • stephenpc joined the channel
      • clouddig joined the channel
      • schristou
        itdependsnetwork: what do you mean by wrong random branch
      • itdependsnetwork
      • jenkins-admin
        JENKINS-21464:Unwanted repetitive builds of the same git commit hash (Resolved) https://issues.jenkins-ci.org/browse/JENKINS-21464
      • villav joined the channel
      • mbenson joined the channel
      • mbenson has quit
      • mbenson joined the channel
      • itdependsnetwork
        ok, I deleted all other branches other than master and the one I am using, now it is pulling the branch and hash I expect it to
      • mbenson_ joined the channel
      • villav has quit
      • Ney
        schristou: how would I change a slave to a differnt master?
      • windows slave
      • robnester joined the channel
      • mbenson has quit
      • malex joined the channel
      • schristou
        Ney: modify the jenkins-slave.xml file and restart the Jenkins service
      • villav joined the channel
      • HasanAtizaz joined the channel
      • samrocke1man joined the channel
      • villav has quit
      • Boniche- is now known as Boniche
      • duemir joined the channel
      • stephend
        does anyone have a working example (Jenkinsfile) of polling a URL (not pollSCM()) - given https://issues.jenkins-ci.org/browse/JENKINS-27301 ?
      • jenkins-admin
        JENKINS-27301:Pipeline support for XTrigger (In Review) https://issues.jenkins-ci.org/browse/JENKINS-27301
      • stephend
        specifically, I want to detect (probably by commit string?) changes to this URL: https://latest.dev.lcip.org/__version__
      • niab has quit
      • samrocke1man has quit
      • Ney
        schristou: the slave gets added, but the service won't intall
      • *install
      • duemir has quit
      • duemir joined the channel
      • segy joined the channel
      • duemir has quit
      • madan joined the channel
      • madan
        hi
      • I want to run exe file post build from jenkins
      • exe file depends on opengl
      • is it possible to run exe ?, please share suggestions
      • schristou
        madan:
      • sure it's possible. just run a bash step
      • madan
        sorry to interrupt, platform is for windows, is it possible?
      • and one more qn, do we need any selenium interaction here?, and also if jenkins server is made to run on remote VM, is it possible to run exe there without display in windows?..
      • schristou
        sorry, not bash, batch script
      • if you create a freestyle or pipeline job you should be able to add a batch step which then you can run your .exe file
      • madan
        ok,will it run if the VM is not having display manager running?
      • since this is for CI stuff, we may not get machines with display support
      • schristou
        it should be fine
      • gli joined the channel
      • madan
        in this case, do you have any suggestions on running batch file under displayless mode?, if so how it can be achieved in windows?. Because, in linux I heard something like xvfb, but for windows, I couldn't get something same
      • vpandey has quit
      • schristou
        so you're wanting to run windows in headless mode, but create an interactive session (similar to xvfb)? Not sure it's possible, but imo it's not a Jenkins specific question and more of a windows usability question.
      • philipgo_ joined the channel
      • madan
        ok, thanks team for the support
      • philipgough has quit
      • sabre1041 joined the channel
      • samrocketman joined the channel
      • samrocketman is now known as Guest68643
      • ky13__ has quit
      • Guest68643 has quit
      • Anticlaus joined the channel
      • Anticlaus has quit
      • fryguy joined the channel
      • clouddig has quit
      • sabre1041 joined the channel
      • ohnx joined the channel
      • madan has quit
      • n0body has quit
      • colemickens joined the channel
      • clouddig joined the channel
      • ky13_ joined the channel
      • colemickens wonders how many bugs aren't filed because they can't be filed as GH Issues.
      • colemickens
        Is there a reason that kubernetes-plugin requires so much configuration? I shouldn't need to point it at kubernetes master, why doesn't it just get that from the kubeconfig I supply? I was taken aback by the 6+ fields. I expected to drop a kubeconfig and a cluster name and be done.
      • OTOH, I had to look at the raw jenkins journald log to see that it was trying to connect to kubernetes.default.svc. 🙁
      • ky13_ has quit
      • Amanas joined the channel